C言語で0から9までの数字を一つずつ増やしながら表示するためのサンプルプログラム

今回は、C言語を用いて0から9までの数字を一つずつ増やしながら表示するためのサンプルプログラムを作成したので紹介したいと思います!

今回のサンプルプログラムを作成するのにあたり、2重for文を用いたのでそこらへんも参考にしてみて下さい!

早速ですが、コードは下記のようになります!

#include <stdio.h>

int main() {
	
	printf("0から9までの数字を一つずつ増やしながら表示します。\n");

	for (int i = 0; i < 10; i++) {
		for (int j=0; j <= i; j++) {
			printf("%d", j);
		}
		printf("\n");

	}

	return 0;
}

それでは、コードを見て行きましょう!

printf("0から9までの数字を一つずつ増やしながら表示します。\n");

上記の部分では、printfの関数を用いて「0から9までの数字を一つずつ増やしながら表示します。」の文言を表示させています。

そうしましたら、次の部分を見てみましょう!

for (int i = 0; i < 10; i++) {
    for (int j=0; j <= i; j++) {
        printf("%d", j);
    }
    printf("\n");

}

ここの部分は、for文を2重に回しています。

最初のfor文でiを0から9までの間で回して、その中でjを0からiまでの間で回しています!

実行結果

0から9までの数字を一つずつ増やしながら表示します。
0
01
012
0123
01234
012345
0123456
01234567
012345678
0123456789